Service Outage Reported for TEST NOTIFICATION

Minor incident IT Support & Campus Resources IT/HR Support Portal (RamsCentral)
2025-07-14 14:32 EDT · 8 months, 4 weeks, 14 hours, 24 minutes

Updates

Investigating

Update yet again.

July 18, 2025 · 11:28 EDT
Investigating

Another update 7/18/25

July 18, 2025 · 11:21 EDT
Investigating

Update # 3

July 15, 2025 · 11:46 EDT
Investigating

Update#2

July 14, 2025 · 14:45 EDT
Investigating

Still working on it.

July 14, 2025 · 14:42 EDT
Issue

We are investigating an issue with [INSERT SERVICE/SYSTEM NAME] which is impacting [INSERT CUSTOMER IMPACT]. We’re working to fix the problem as quickly as we can.
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or [email protected].

July 14, 2025 · 14:32 EDT

← Back